Protection against stack-based memory corruption errors using SafeStack
[oota-llvm.git] / lib / Transforms / Instrumentation / CMakeLists.txt
index 7b3a927a4e685f1da610a96b97c85aca0f64d32a..9b81f4bb161961f8e73ef0eb4f6993de555d7455 100644 (file)
@@ -1,15 +1,17 @@
 add_llvm_library(LLVMInstrumentation
-  EdgeProfiling.cpp
+  AddressSanitizer.cpp
+  BoundsChecking.cpp
+  DataFlowSanitizer.cpp
   GCOVProfiling.cpp
+  MemorySanitizer.cpp
   Instrumentation.cpp
-  OptimalEdgeProfiling.cpp
-  PathProfiling.cpp
-  ProfilingUtils.cpp
-  )
+  InstrProfiling.cpp
+  SafeStack.cpp
+  SanitizerCoverage.cpp
+  ThreadSanitizer.cpp
 
-add_llvm_library_dependencies(LLVMInstrumentation
-  LLVMAnalysis
-  LLVMCore
-  LLVMSupport
-  LLVMTransformUtils
+  ADDITIONAL_HEADER_DIRS
+  ${LLVM_MAIN_INCLUDE_DIR}/llvm/Transforms
   )
+
+add_dependencies(LLVMInstrumentation intrinsics_gen)