Protection against stack-based memory corruption errors using SafeStack
[oota-llvm.git] / lib / Transforms / Instrumentation / CMakeLists.txt
index 128bf489787cfbfa54b0b6657f28d4a67810c5f5..9b81f4bb161961f8e73ef0eb4f6993de555d7455 100644 (file)
@@ -1,5 +1,17 @@
 add_llvm_library(LLVMInstrumentation
-  EdgeProfiling.cpp
-  OptimalEdgeProfiling.cpp
-  ProfilingUtils.cpp
+  AddressSanitizer.cpp
+  BoundsChecking.cpp
+  DataFlowSanitizer.cpp
+  GCOVProfiling.cpp
+  MemorySanitizer.cpp
+  Instrumentation.cpp
+  InstrProfiling.cpp
+  SafeStack.cpp
+  SanitizerCoverage.cpp
+  ThreadSanitizer.cpp
+
+  ADDITIONAL_HEADER_DIRS
+  ${LLVM_MAIN_INCLUDE_DIR}/llvm/Transforms
   )
+
+add_dependencies(LLVMInstrumentation intrinsics_gen)