move the bounds checking pass to the instrumentation folder, where it belongs. I...
[oota-llvm.git] / lib / Transforms / Instrumentation / CMakeLists.txt
index a4a1fef51f4c900fad51defabef9660fdd5c3e63..00de882f17117a8867510066cef8399ea578c1e0 100644 (file)
@@ -1,9 +1,14 @@
 add_llvm_library(LLVMInstrumentation
   AddressSanitizer.cpp
+  BoundsChecking.cpp
   EdgeProfiling.cpp
+  FunctionBlackList.cpp
   GCOVProfiling.cpp
   Instrumentation.cpp
   OptimalEdgeProfiling.cpp
   PathProfiling.cpp
   ProfilingUtils.cpp
+  ThreadSanitizer.cpp
   )
+
+add_dependencies(LLVMInstrumentation intrinsics_gen)