[function-attrs] Refactor code to handle shorter code with early exits.
[oota-llvm.git] / lib / Transforms / InstCombine / CMakeLists.txt
index 96b016650e2699017c3bded6907b582680d8a192..0ed8e6273dbc6474a8a856624438c5196c54016d 100644 (file)
@@ -1,7 +1,21 @@
 add_llvm_library(LLVMInstCombine
   InstructionCombining.cpp
+  InstCombineAddSub.cpp
+  InstCombineAndOrXor.cpp
+  InstCombineCalls.cpp
+  InstCombineCasts.cpp
   InstCombineCompares.cpp
+  InstCombineLoadStoreAlloca.cpp
+  InstCombineMulDivRem.cpp
+  InstCombinePHI.cpp
+  InstCombineSelect.cpp
+  InstCombineShifts.cpp
   InstCombineSimplifyDemanded.cpp
+  InstCombineVectorOps.cpp
+
+  ADDITIONAL_HEADER_DIRS
+  ${LLVM_MAIN_INCLUDE_DIR}/llvm/Transforms
+  ${LLVM_MAIN_INCLUDE_DIR}/llvm/Transforms/InstCombine
   )
 
-target_link_libraries (LLVMInstCombine LLVMTransformUtils)
+add_dependencies(LLVMInstCombine intrinsics_gen)