[InstCombine] insert a new shuffle in a safe place (PR25999)
[oota-llvm.git] / lib / Transforms / InstCombine / CMakeLists.txt
index 2852a8825788c6d48d48b26417b8f22aee38e67e..0ed8e6273dbc6474a8a856624438c5196c54016d 100644 (file)
@@ -1,9 +1,21 @@
 add_llvm_library(LLVMInstCombine
   InstructionCombining.cpp
+  InstCombineAddSub.cpp
+  InstCombineAndOrXor.cpp
+  InstCombineCalls.cpp
   InstCombineCasts.cpp
   InstCombineCompares.cpp
+  InstCombineLoadStoreAlloca.cpp
+  InstCombineMulDivRem.cpp
   InstCombinePHI.cpp
+  InstCombineSelect.cpp
+  InstCombineShifts.cpp
   InstCombineSimplifyDemanded.cpp
+  InstCombineVectorOps.cpp
+
+  ADDITIONAL_HEADER_DIRS
+  ${LLVM_MAIN_INCLUDE_DIR}/llvm/Transforms
+  ${LLVM_MAIN_INCLUDE_DIR}/llvm/Transforms/InstCombine
   )
 
-target_link_libraries (LLVMInstCombine LLVMTransformUtils)
+add_dependencies(LLVMInstCombine intrinsics_gen)