Reapply r238011 with a fix for the trap instruction.
[oota-llvm.git] / lib / Target / X86 / CMakeLists.txt
index be61b4701aa367fa1331ea5e181680b333a63a9e..fba2c280d200141eba3cb468ea97803025d39df0 100644 (file)
@@ -15,6 +15,7 @@ add_public_tablegen_target(X86CommonTableGen)
 set(sources
   X86AsmPrinter.cpp
   X86CallFrameOptimization.cpp
+  X86ExpandPseudo.cpp
   X86FastISel.cpp
   X86FloatingPoint.cpp
   X86FrameLowering.cpp
@@ -32,6 +33,7 @@ set(sources
   X86TargetTransformInfo.cpp
   X86VZeroUpper.cpp
   X86FixupLEAs.cpp
+  X86WinEHState.cpp
   )
 
 if( CMAKE_CL_64 )