Add to the list of cmake files the object file, not the asm file. This
[oota-llvm.git] / lib / Target / X86 / CMakeLists.txt
index e62dfca491d95eb488b017fddb2aa22b7e3e9c34..036dbcda2147b05c0a146fce2744a3d4fbbc0599 100644 (file)
@@ -47,7 +47,7 @@ if( CMAKE_CL_64 )
     MAIN_DEPENDENCY X86CompilationCallback_Win64.asm
     COMMAND ${CMAKE_ASM_MASM_COMPILER} /Fo ${CMAKE_CURRENT_BINARY_DIR}/X86CompilationCallback_Win64.obj /c ${CMAKE_CURRENT_SOURCE_DIR}/X86CompilationCallback_Win64.asm
    )
-   set(sources ${sources} X86CompilationCallback_Win64.asm)
+   set(sources ${sources} ${CMAKE_CURRENT_BINARY_DIR}/X86CompilationCallback_Win64.obj)
 endif()
 
 add_llvm_target(X86CodeGen ${sources})