Call the version of ConvertCostTableLookup that takes a statically sized array rather...
[oota-llvm.git] / lib / Target / CMakeLists.txt
index 4d02d1e4a5b9e24beeb13e92aaa7176319c277e1..e6d0199952f403c6c998fa70d95b816441997466 100644 (file)
@@ -1,16 +1,19 @@
+list(APPEND LLVM_COMMON_DEPENDS intrinsics_gen)
+
 add_llvm_library(LLVMTarget
-  Mangler.cpp
-  SubtargetFeature.cpp
   Target.cpp
-  TargetAsmInfo.cpp
-  TargetAsmLexer.cpp
-  TargetData.cpp
-  TargetELFWriterInfo.cpp
-  TargetFrameLowering.cpp
-  TargetInstrInfo.cpp
   TargetIntrinsicInfo.cpp
   TargetLoweringObjectFile.cpp
   TargetMachine.cpp
-  TargetRegisterInfo.cpp
-  TargetSubtarget.cpp
+  TargetMachineC.cpp
+  TargetRecip.cpp
+  TargetSubtargetInfo.cpp
+
+  ADDITIONAL_HEADER_DIRS
+  ${LLVM_MAIN_INCLUDE_DIR}/llvm/Target
   )
+
+foreach(t ${LLVM_TARGETS_TO_BUILD})
+  message(STATUS "Targeting ${t}")
+  add_subdirectory(${t})
+endforeach()