remove the remnants of TargetMachOWriterInfo.
[oota-llvm.git] / lib / Target / CMakeLists.txt
index 7cffd0e53c17892c861d5e320d7fcad333703194..43ebdac528ca1caae6952dcfcce6522f1632bc0d 100644 (file)
@@ -1,18 +1,15 @@
 add_llvm_library(LLVMTarget
-  DarwinTargetAsmInfo.cpp
-  ELFTargetAsmInfo.cpp
+  Mangler.cpp
   SubtargetFeature.cpp
   Target.cpp
-  TargetAsmInfo.cpp
+  TargetAsmLexer.cpp
   TargetData.cpp
   TargetELFWriterInfo.cpp
   TargetFrameInfo.cpp
   TargetInstrInfo.cpp
-  TargetMachOWriterInfo.cpp
+  TargetIntrinsicInfo.cpp
+  TargetLoweringObjectFile.cpp
   TargetMachine.cpp
-  TargetMachineRegistry.cpp
   TargetRegisterInfo.cpp
   TargetSubtarget.cpp
   )
-
-# TODO: Support other targets besides X86. See Makefile.