Revert "make reciprocal estimate code generation more flexible by adding command...
[oota-llvm.git] / lib / Target / CMakeLists.txt
index a21ccd590c77700007afa21c160bd5085f5ccf93..1805437b12f71575ac5579e47d3a1276bfac4fbc 100644 (file)
@@ -1,19 +1,18 @@
+list(APPEND LLVM_COMMON_DEPENDS intrinsics_gen)
+
 add_llvm_library(LLVMTarget
-  COFFTargetAsmInfo.cpp
-  DarwinTargetAsmInfo.cpp
-  SubtargetFeature.cpp
   Target.cpp
-  TargetAsmInfo.cpp
-  TargetData.cpp
-  TargetELFWriterInfo.cpp
-  TargetFrameInfo.cpp
-  TargetInstrInfo.cpp
   TargetIntrinsicInfo.cpp
   TargetLoweringObjectFile.cpp
-  TargetMachOWriterInfo.cpp
   TargetMachine.cpp
-  TargetRegisterInfo.cpp
-  TargetSubtarget.cpp
+  TargetMachineC.cpp
+  TargetSubtargetInfo.cpp
+
+  ADDITIONAL_HEADER_DIRS
+  ${LLVM_MAIN_INCLUDE_DIR}/llvm/Target
   )
 
-# TODO: Support other targets besides X86. See Makefile.
+foreach(t ${LLVM_TARGETS_TO_BUILD})
+  message(STATUS "Targeting ${t}")
+  add_subdirectory(${t})
+endforeach()