Add AVR.td and AVRRegisterInfo.td
[oota-llvm.git] / lib / Target / AVR / CMakeLists.txt
index e588c4262737904f6ae10121f858d37596aab122..9c29f2086e6c45ace7e54ce2952c82bf4093aa45 100644 (file)
@@ -1,4 +1,7 @@
+set(LLVM_TARGET_DEFINITIONS AVR.td)
 
+tablegen(LLVM AVRGenRegisterInfo.inc -gen-register-info)
+add_public_tablegen_target(AVRCommonTableGen)
 
 add_llvm_target(AVRCodeGen
     AVRTargetMachine.cpp