Tell Valgrind when we modify already-executed machine code so it knows
[oota-llvm.git] / lib / System / CMakeLists.txt
index 2945e33d5b1cccf7faf49339492c8995849ac1af..b43c3afa52482917b12c61184b06d21ac006a5f5 100644 (file)
@@ -12,10 +12,12 @@ add_llvm_library(LLVMSystem
   Process.cpp
   Program.cpp
   RWMutex.cpp
+  SearchForAddressOfSpecialSymbol.cpp
   Signals.cpp
   ThreadLocal.cpp
   Threading.cpp
   TimeValue.cpp
+  Valgrind.cpp
   Unix/Alarm.inc
   Unix/Host.inc
   Unix/Memory.inc
@@ -42,5 +44,5 @@ add_llvm_library(LLVMSystem
   )
 
 if( BUILD_SHARED_LIBS AND NOT WIN32 )
-  target_link_libraries(LLVMSystem dl)
+  target_link_libraries(LLVMSystem ${CMAKE_DL_LIBS})
 endif()