[CMake] Use target_link_libraries(INTERFACE|PRIVATE) on CMake-2.8.12 to increase...
[oota-llvm.git] / lib / Support / CMakeLists.txt
index 0b5f623d3a9f5a66b2171d50b5cb2794a8211b4d..a32d238d28779543d8d42ef4e9368dbb87d235aa 100644 (file)
@@ -142,5 +142,5 @@ if( NOT MSVC )
     endif()
   endif( MINGW )
 endif( NOT MSVC )
-target_link_libraries(LLVMSupport ${system_libs})
+target_link_libraries(LLVMSupport ${cmake_2_8_12_INTERFACE} ${system_libs})
 set_property(TARGET LLVMSupport PROPERTY LLVM_SYSTEM_LIBS "${system_libs}")