Rewrite the CMake build to use explicit dependencies between libraries,
[oota-llvm.git] / lib / MC / CMakeLists.txt
index 7b9b355339a10bb8b3ee4cee1b3434135b119bc7..a3303a1bf24d12652f461fa8c48d629c519fb8f0 100644 (file)
@@ -1,12 +1,17 @@
 add_llvm_library(LLVMMC
+  ELFObjectWriter.cpp
   MCAsmInfo.cpp
   MCAsmInfoCOFF.cpp
   MCAsmInfoDarwin.cpp
   MCAsmStreamer.cpp
   MCAssembler.cpp
   MCCodeEmitter.cpp
+  MCCodeGenInfo.cpp
   MCContext.cpp
   MCDisassembler.cpp
+  MCELF.cpp
+  MCELFObjectTargetWriter.cpp
+  MCELFStreamer.cpp
   MCExpr.cpp
   MCInst.cpp
   MCInstPrinter.cpp
@@ -14,18 +19,33 @@ add_llvm_library(LLVMMC
   MCDwarf.cpp
   MCLoggingStreamer.cpp
   MCMachOStreamer.cpp
+  MCMachObjectTargetWriter.cpp
   MCNullStreamer.cpp
+  MCObjectFileInfo.cpp
   MCObjectStreamer.cpp
   MCObjectWriter.cpp
+  MCPureStreamer.cpp
   MCSection.cpp
   MCSectionCOFF.cpp
   MCSectionELF.cpp
   MCSectionMachO.cpp
   MCStreamer.cpp
+  MCSubtargetInfo.cpp
   MCSymbol.cpp
   MCValue.cpp
+  MCWin64EH.cpp
   MachObjectWriter.cpp
   WinCOFFStreamer.cpp
   WinCOFFObjectWriter.cpp
-  TargetAsmBackend.cpp
+  SubtargetFeature.cpp
+  MCAsmBackend.cpp
+  MCTargetAsmLexer.cpp
   )
+
+add_llvm_library_dependencies(LLVMMC
+  LLVMObject
+  LLVMSupport
+  )
+
+add_subdirectory(MCParser)
+add_subdirectory(MCDisassembler)