Provide a way to specify inliner's attribute compatibility and merging.
[oota-llvm.git] / lib / IR / CMakeLists.txt
index 472178f5122dffedba6287e98fd6e780966cc49e..eb67c525ce21c78dc9710b65604d49673ea00cd4 100644 (file)
@@ -1,3 +1,7 @@
+set(LLVM_TARGET_DEFINITIONS AttributesCompatFunc.td)
+tablegen(LLVM AttributesCompatFunc.inc -gen-attrs)
+add_public_tablegen_target(AttributeCompatFuncTableGen)
+
 add_llvm_library(LLVMCore
   AsmWriter.cpp
   Attributes.cpp