Use std::is_sorted and std::none_of instead of manual loops. NFC
[oota-llvm.git] / lib / IR / CMakeLists.txt
index 2ad5fdb25be1aa603d1acbbede23a29a84604d13..40b4ec65e22be14bf17be2e405468444c4f4da63 100644 (file)
@@ -1,34 +1,48 @@
+set(LLVM_TARGET_DEFINITIONS AttributesCompatFunc.td)
+tablegen(LLVM AttributesCompatFunc.inc -gen-attrs)
+add_public_tablegen_target(AttributeCompatFuncTableGen)
+
 add_llvm_library(LLVMCore
   AsmWriter.cpp
   Attributes.cpp
   AutoUpgrade.cpp
   BasicBlock.cpp
+  Comdat.cpp
   ConstantFold.cpp
+  ConstantRange.cpp
   Constants.cpp
   Core.cpp
   DIBuilder.cpp
   DataLayout.cpp
   DebugInfo.cpp
+  DebugInfoMetadata.cpp
   DebugLoc.cpp
+  DiagnosticInfo.cpp
+  DiagnosticPrinter.cpp
   Dominators.cpp
   Function.cpp
   GCOV.cpp
   GVMaterializer.cpp
   Globals.cpp
   IRBuilder.cpp
+  IRPrintingPasses.cpp
   InlineAsm.cpp
   Instruction.cpp
   Instructions.cpp
   IntrinsicInst.cpp
   LLVMContext.cpp
   LLVMContextImpl.cpp
-  LeakDetector.cpp
   LegacyPassManager.cpp
+  MDBuilder.cpp
+  Mangler.cpp
   Metadata.cpp
   Module.cpp
+  Operator.cpp
   Pass.cpp
+  PassManager.cpp
   PassRegistry.cpp
-  PrintModulePass.cpp
+  Statepoint.cpp
+  FunctionInfo.cpp
   Type.cpp
   TypeFinder.cpp
   Use.cpp
@@ -37,15 +51,17 @@ add_llvm_library(LLVMCore
   ValueSymbolTable.cpp
   ValueTypes.cpp
   Verifier.cpp
-  )
 
-# Workaround: It takes over 20 minutes to compile with msvc10.
-# FIXME: Suppressing optimizations to core libraries would not be good thing.
-if( MSVC_VERSION LESS 1700 )
-set_property(
-  SOURCE Function.cpp
-  PROPERTY COMPILE_FLAGS "/Og-"
+  ADDITIONAL_HEADER_DIRS
+  ${LLVM_MAIN_INCLUDE_DIR}/llvm/IR
   )
+
+# PR24785: Workaround for hanging compilation.
+if( MSVC_VERSION EQUAL 1800)
+  set_property(
+    SOURCE Function.cpp
+    PROPERTY COMPILE_FLAGS "/Og-"
+    )
 endif()
 
 add_dependencies(LLVMCore intrinsics_gen)