Handles libffi on the CMake build.
[oota-llvm.git] / lib / ExecutionEngine / Interpreter / CMakeLists.txt
index dff97fa26e8f57338bebef20621f802daa0f8e2f..39df555d5e294c38afca882c20a4d6f042854790 100644 (file)
@@ -1,5 +1,21 @@
+# If the user required a custom path for ffi headers, use it on its
+# abolute form (see config-ix.cmake):
+if( FFI_INCLUDE_DIR )
+  include_directories( ${FFI_INCLUDE_PATH} )
+endif()
+
+# If the user required a custom path for libffi, use it on its abolute
+# form (see config-ix.cmake):
+if( FFI_LIBRARY_DIR )
+  link_directories( ${FFI_LIBRARY_PATH} )
+endif()
+
 add_llvm_library(LLVMInterpreter
   Execution.cpp
   ExternalFunctions.cpp
   Interpreter.cpp
   )
+
+if( LLVM_ENABLE_FFI )
+  target_link_libraries( LLVMInterpreter ffi )
+endif()