[MCJIT] Replace JITEventListener::anchor (temporarily removed in r222861), and
[oota-llvm.git] / lib / ExecutionEngine / CMakeLists.txt
index 0e118ccd904f4628ddcd8c008145d4708edee69a..dc2fe9bf97f3ec420fd35935d9b037380b1a6560 100644 (file)
@@ -1,4 +1,21 @@
+
+
 add_llvm_library(LLVMExecutionEngine
   ExecutionEngine.cpp
   ExecutionEngineBindings.cpp
+  GDBRegistrationListener.cpp
+  RTDyldMemoryManager.cpp
+  TargetSelect.cpp
   )
+
+add_subdirectory(Interpreter)
+add_subdirectory(MCJIT)
+add_subdirectory(RuntimeDyld)
+
+if( LLVM_USE_OPROFILE )
+  add_subdirectory(OProfileJIT)
+endif( LLVM_USE_OPROFILE )
+
+if( LLVM_USE_INTEL_JITEVENTS )
+  add_subdirectory(IntelJITEvents)
+endif( LLVM_USE_INTEL_JITEVENTS )