Exposing MCJIT through C API
[oota-llvm.git] / lib / ExecutionEngine / CMakeLists.txt
index 8bff2654d6c6397e9403159c9dc253ddc5fbd9f1..cb11bfe93c7c9078aac8075c4bccf7df6dd5a629 100644 (file)
@@ -1,9 +1,20 @@
+
+
 add_llvm_library(LLVMExecutionEngine
   ExecutionEngine.cpp
   ExecutionEngineBindings.cpp
+  TargetSelect.cpp
   )
 
 add_subdirectory(Interpreter)
 add_subdirectory(JIT)
 add_subdirectory(MCJIT)
 add_subdirectory(RuntimeDyld)
+
+if( LLVM_USE_OPROFILE )
+  add_subdirectory(OProfileJIT)
+endif( LLVM_USE_OPROFILE )
+
+if( LLVM_USE_INTEL_JITEVENTS )
+  add_subdirectory(IntelJITEvents)
+endif( LLVM_USE_INTEL_JITEVENTS )