Taints the non-acquire RMW's store address with the load part
[oota-llvm.git] / lib / CodeGen / CMakeLists.txt
index b2a1efc9c25ba3ea52685fc665fb5ef0d74c4f11..765b5ab9a5770a7be1198778023835f8d2a8b1a6 100644 (file)
@@ -25,7 +25,9 @@ add_llvm_library(LLVMCodeGen
   ExecutionDepsFix.cpp
   ExpandISelPseudos.cpp
   ExpandPostRAPseudos.cpp
+  LiveDebugValues.cpp
   FaultMaps.cpp
+  FuncletLayout.cpp
   GCMetadata.cpp
   GCMetadataPrinter.cpp
   GCRootLowering.cpp
@@ -119,6 +121,7 @@ add_llvm_library(LLVMCodeGen
   StackMaps.cpp
   StatepointExampleGC.cpp
   TailDuplication.cpp
+  TaintRelaxedAtomicsUtils.cpp
   TargetFrameLoweringImpl.cpp
   TargetInstrInfo.cpp
   TargetLoweringBase.cpp