CodeGen: refactor DwarfException
[oota-llvm.git] / lib / CodeGen / AsmPrinter / CMakeLists.txt
index f6ce17d221aa55f039a48e34cea0432d9249dfb4..f555f212a978130c2c0f33e3f24752846a57672f 100644 (file)
@@ -1,24 +1,23 @@
 add_llvm_library(LLVMAsmPrinter
+  AddressPool.cpp
   ARMException.cpp
   AsmPrinter.cpp
   AsmPrinterDwarf.cpp
   AsmPrinterInlineAsm.cpp
+  DbgValueHistoryCalculator.cpp
   DIE.cpp
+  DIEHash.cpp
   DwarfAccelTable.cpp
   DwarfCFIException.cpp
-  DwarfCompileUnit.cpp
   DwarfDebug.cpp
-  DwarfException.cpp
+  DwarfFile.cpp
+  DwarfStringPool.cpp
+  DwarfUnit.cpp
+  EHStreamer.cpp
+  ErlangGCPrinter.cpp
   OcamlGCPrinter.cpp
   Win64Exception.cpp
+  WinCodeViewLineTables.cpp
   )
 
-add_llvm_library_dependencies(LLVMAsmPrinter
-  LLVMAnalysis
-  LLVMCodeGen
-  LLVMCore
-  LLVMMC
-  LLVMMCParser
-  LLVMSupport
-  LLVMTarget
-  )
+add_dependencies(LLVMAsmPrinter intrinsics_gen)