Revert "CMake: Get rid of LLVMLibDeps.cmake and export the libraries normally."
[oota-llvm.git] / lib / CodeGen / AsmPrinter / CMakeLists.txt
index ef6e157e86d0e2e092e07436883becbb7c9c122d..ca8b8436c11fd576d3164b2603d7307d10041aff 100644 (file)
@@ -8,11 +8,4 @@ add_llvm_library(LLVMAsmPrinter
   OcamlGCPrinter.cpp
   )
 
-target_link_libraries (LLVMAsmPrinter
-  LLVMAnalysis
-  LLVMCodeGen
-  LLVMCore
-  LLVMMC
-  LLVMMCParser
-  LLVMTarget
-  )
+target_link_libraries (LLVMAsmPrinter LLVMMCParser)