Revert r200340, "Add line table debug info to COFF files when using a win32 triple."
[oota-llvm.git] / lib / CodeGen / AsmPrinter / CMakeLists.txt
index ef6e157e86d0e2e092e07436883becbb7c9c122d..2ad24e1af99225a5164bc0b64526f9ff55ab6ba5 100644 (file)
@@ -1,18 +1,18 @@
 add_llvm_library(LLVMAsmPrinter
+  ARMException.cpp
   AsmPrinter.cpp
   AsmPrinterDwarf.cpp
   AsmPrinterInlineAsm.cpp
   DIE.cpp
+  DIEHash.cpp
+  DwarfAccelTable.cpp
+  DwarfCFIException.cpp
   DwarfDebug.cpp
   DwarfException.cpp
+  DwarfUnit.cpp
+  ErlangGCPrinter.cpp
   OcamlGCPrinter.cpp
+  Win64Exception.cpp
   )
 
-target_link_libraries (LLVMAsmPrinter
-  LLVMAnalysis
-  LLVMCodeGen
-  LLVMCore
-  LLVMMC
-  LLVMMCParser
-  LLVMTarget
-  )
+add_dependencies(LLVMAsmPrinter intrinsics_gen)