Move TargetTransformInfo to live under the Analysis library. This no
[oota-llvm.git] / lib / Analysis / CMakeLists.txt
index 2a8b639ebb2a4355cc84374c0e78340dce7fff52..78abe0ff6f609c017b343fa47e0f32551e98ab40 100644 (file)
@@ -6,36 +6,62 @@ add_llvm_library(LLVMAnalysis
   AliasSetTracker.cpp
   Analysis.cpp
   BasicAliasAnalysis.cpp
+  BlockFrequencyInfo.cpp
+  BranchProbabilityInfo.cpp
   CFGPrinter.cpp
   CaptureTracking.cpp
+  CostModel.cpp
+  CodeMetrics.cpp
   ConstantFolding.cpp
   DbgInfoPrinter.cpp
-  DebugInfo.cpp
+  DependenceAnalysis.cpp
+  DomPrinter.cpp
+  DominanceFrontier.cpp
   IVUsers.cpp
+  InlineCost.cpp
   InstCount.cpp
+  InstructionSimplify.cpp
   Interval.cpp
   IntervalPartition.cpp
+  LazyValueInfo.cpp
   LibCallAliasAnalysis.cpp
   LibCallSemantics.cpp
-  LiveValues.cpp
-  LoopDependenceAnalysis.cpp
+  Lint.cpp
+  Loads.cpp
   LoopInfo.cpp
   LoopPass.cpp
-  MallocHelper.cpp
+  MemDepPrinter.cpp
+  MemoryBuiltins.cpp
   MemoryDependenceAnalysis.cpp
-  PointerTracking.cpp
+  ModuleDebugInfoPrinter.cpp
+  NoAliasAnalysis.cpp
+  PHITransAddr.cpp
+  PathNumbering.cpp
+  PathProfileInfo.cpp
+  PathProfileVerifier.cpp
   PostDominators.cpp
   ProfileEstimatorPass.cpp
   ProfileInfo.cpp
   ProfileInfoLoader.cpp
   ProfileInfoLoaderPass.cpp
   ProfileVerifierPass.cpp
+  ProfileDataLoader.cpp
+  ProfileDataLoaderPass.cpp
+  PtrUseVisitor.cpp
+  RegionInfo.cpp
+  RegionPass.cpp
+  RegionPrinter.cpp
   ScalarEvolution.cpp
   ScalarEvolutionAliasAnalysis.cpp
   ScalarEvolutionExpander.cpp
+  ScalarEvolutionNormalization.cpp
   SparsePropagation.cpp
+  TargetTransformInfo.cpp
   Trace.cpp
+  TypeBasedAliasAnalysis.cpp
   ValueTracking.cpp
   )
 
-target_link_libraries (LLVMAnalysis LLVMSupport)
+add_dependencies(LLVMAnalysis intrinsics_gen)
+
+add_subdirectory(IPA)