Add bogus conditional branch before stlx
[oota-llvm.git] / include / llvm / CMakeLists.txt
index 523f231277894cf66f0ace440ed9c0fcbbe8cdea..ff805396eb0c85af96dde63c972bd56b957c904f 100644 (file)
@@ -1,8 +1,7 @@
-set(LLVM_TARGET_DEFINITIONS Intrinsics.td)
+add_subdirectory(IR)
 
-tablegen(Intrinsics.gen -gen-intrinsic)
-
-add_custom_target(intrinsics_gen ALL
-  DEPENDS ${llvm_builded_incs_dir}/Intrinsics.gen)
-
-set(LLVM_COMMON_DEPENDS ${LLVM_COMMON_DEPENDS} intrinsics_gen PARENT_SCOPE)
+# If we're doing an out-of-tree build, copy a module map for generated
+# header files into the build area.
+if (NOT "${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_DIR}")
+  configure_file(module.modulemap.build module.modulemap COPYONLY)
+endif (NOT "${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_DIR}")