Move all of the header files which are involved in modelling the LLVM IR
[oota-llvm.git] / include / llvm / CMakeLists.txt
index f8cb4250584c45441072c1c2912ffdb6fde55c21..32ffca75bb7a0f5e9bc94963c3671dd855f7557a 100644 (file)
@@ -1,10 +1,4 @@
-set(LLVM_TARGET_DEFINITIONS Intrinsics.td)
-
-tablegen(LLVM Intrinsics.gen -gen-intrinsic)
-
-add_custom_target(intrinsics_gen ALL
-  DEPENDS ${llvm_builded_incs_dir}/Intrinsics.gen)
-set_target_properties(intrinsics_gen PROPERTIES FOLDER "Tablegenning")
+add_subdirectory(IR)
 
 if( MSVC_IDE OR XCODE )
   # Creates a dummy target containing all headers for the benefit of