[CMake] Update LLVM_LINK_COMPONENTS for each CMakeLists.txt.
[oota-llvm.git] / examples / ParallelJIT / CMakeLists.txt
index 91ac5ef4675128d85f2b8d348cf8303ffb821d4a..8673917f5589d7da3d21818051dbbf166d9bd24e 100644 (file)
@@ -1,9 +1,16 @@
+set(LLVM_LINK_COMPONENTS
+  Core
+  ExecutionEngine
+  Interpreter
+  JIT
+  Support
+  nativecodegen
+  )
+
 add_llvm_example(ParallelJIT
   ParallelJIT.cpp
   )
 
-add_llvm_link_components(ParallelJIT jit interpreter nativecodegen)
-
 if(HAVE_LIBPTHREAD)
   target_link_libraries(ParallelJIT pthread)
 endif(HAVE_LIBPTHREAD)