ReleaseNotes: shrink-wrapping; by Quentin Colombet
[oota-llvm.git] / examples / ParallelJIT / CMakeLists.txt
index d8dd7084c40df83b359ffeb44a8d3b909ed3b6db..07c0a085b91f63bbc723038ee9df0dd71714ad11 100644 (file)
@@ -1,7 +1,16 @@
-set(LLVM_LINK_COMPONENTS jit interpreter nativecodegen)
+set(LLVM_LINK_COMPONENTS
+  Core
+  ExecutionEngine
+  Interpreter
+  MC
+  Support
+  nativecodegen
+  )
 
 add_llvm_example(ParallelJIT
   ParallelJIT.cpp
   )
 
-target_link_libraries(ParallelJIT pthread)
+if(HAVE_LIBPTHREAD)
+  target_link_libraries(ParallelJIT pthread)
+endif(HAVE_LIBPTHREAD)