[Orc][Kaleidoscope] Add an example of extreme-laziness in Orc.
[oota-llvm.git] / examples / Kaleidoscope / Orc / fully_lazy / CMakeLists.txt
diff --git a/examples/Kaleidoscope/Orc/fully_lazy/CMakeLists.txt b/examples/Kaleidoscope/Orc/fully_lazy/CMakeLists.txt
new file mode 100644 (file)
index 0000000..4488681
--- /dev/null
@@ -0,0 +1,12 @@
+set(LLVM_LINK_COMPONENTS
+  Core
+  ExecutionEngine
+  Object
+  RuntimeDyld
+  Support
+  native
+  )
+
+add_kaleidoscope_chapter(Kaleidoscope-Orc-lazy_irgen
+  toy.cpp
+  )