Kaleidoscope: Prune unused libdeps.
[oota-llvm.git] / examples / Kaleidoscope / Chapter8 / CMakeLists.txt
index a09c6bee8b56803cfaf65a726b62077a4113d7a6..e335cb48ac7a244d19bb9f36ddd60c7cb827e9c1 100644 (file)
@@ -1,18 +1,11 @@
 set(LLVM_LINK_COMPONENTS
-  Analysis
   Core
   ExecutionEngine
-  InstCombine
-  MC
-  ScalarOpts
+  Object
   Support
-  TransformUtils
-  nativecodegen
-  mcjit
+  native
   )
 
-set(LLVM_REQUIRES_RTTI 1)
-
-add_llvm_example(Kaleidoscope-Ch8
+add_kaleidoscope_chapter(Kaleidoscope-Ch8
   toy.cpp
   )