Kaleidoscope: Prune unused libdeps.
[oota-llvm.git] / examples / Kaleidoscope / Chapter8 / CMakeLists.txt
index 1a9577223992e6aa11fa0897d2432616d65901b1..e335cb48ac7a244d19bb9f36ddd60c7cb827e9c1 100644 (file)
@@ -1,18 +1,11 @@
 set(LLVM_LINK_COMPONENTS
-  Analysis
   Core
   ExecutionEngine
-  InstCombine
-  MC
-  ScalarOpts
+  Object
   Support
-  TransformUtils
   native
-  mcjit
   )
 
-set(LLVM_REQUIRES_RTTI 1)
-
 add_kaleidoscope_chapter(Kaleidoscope-Ch8
   toy.cpp
   )