Kaleidoscope: Prune unused libdeps.
[oota-llvm.git] / examples / Kaleidoscope / Chapter8 / CMakeLists.txt
index 053916f441d9da00805c0171ea19b0586cb2d28a..e335cb48ac7a244d19bb9f36ddd60c7cb827e9c1 100644 (file)
@@ -1,17 +1,11 @@
 set(LLVM_LINK_COMPONENTS
-  Analysis
   Core
   ExecutionEngine
-  InstCombine
-  MC
-  ScalarOpts
+  Object
   Support
-  TransformUtils
-  nativecodegen
+  native
   )
 
-set(LLVM_REQUIRES_RTTI 1)
-
-add_llvm_example(Kaleidoscope-Ch8
+add_kaleidoscope_chapter(Kaleidoscope-Ch8
   toy.cpp
   )