Recommit r246175 - Add Kaleidoscope regression tests, with a fix to make sure
[oota-llvm.git] / examples / Kaleidoscope / Chapter8 / CMakeLists.txt
index 1a9577223992e6aa11fa0897d2432616d65901b1..d9b5cc421be397e6a7df382b4901505caec67f6d 100644 (file)
@@ -1,18 +1,13 @@
 set(LLVM_LINK_COMPONENTS
-  Analysis
   Core
   ExecutionEngine
-  InstCombine
-  MC
-  ScalarOpts
+  Object
   Support
-  TransformUtils
   native
-  mcjit
   )
 
-set(LLVM_REQUIRES_RTTI 1)
-
 add_kaleidoscope_chapter(Kaleidoscope-Ch8
   toy.cpp
   )
+
+export_executable_symbols(Kaleidoscope-Ch8)