Add Chapter 8 to the Kaleidoscope tutorial. This chapter adds
[oota-llvm.git] / examples / Kaleidoscope / Chapter8 / CMakeLists.txt
diff --git a/examples/Kaleidoscope/Chapter8/CMakeLists.txt b/examples/Kaleidoscope/Chapter8/CMakeLists.txt
new file mode 100644 (file)
index 0000000..053916f
--- /dev/null
@@ -0,0 +1,17 @@
+set(LLVM_LINK_COMPONENTS
+  Analysis
+  Core
+  ExecutionEngine
+  InstCombine
+  MC
+  ScalarOpts
+  Support
+  TransformUtils
+  nativecodegen
+  )
+
+set(LLVM_REQUIRES_RTTI 1)
+
+add_llvm_example(Kaleidoscope-Ch8
+  toy.cpp
+  )