CMake: Get rid of LLVMLibDeps.cmake and export the libraries normally.
[oota-llvm.git] / examples / Kaleidoscope / Chapter6 / CMakeLists.txt
index 2e15a5f7dfc60b10639fc26ef71be543c3fd53af..002e0d4670beb8f75d3220cb5d32258a4db2314c 100644 (file)
@@ -1,5 +1,6 @@
-set(LLVM_LINK_COMPONENTS core jit interpreter native)
-
 add_llvm_example(Kaleidoscope-Ch6
   toy.cpp
   )
+
+add_llvm_link_components(Kaleidoscope-Ch6 jit interpreter native)
+target_link_libraries(Kaleidoscope-Ch6 LLVMCore)