Kaleidoscope: Prune unused libdeps.
[oota-llvm.git] / examples / Kaleidoscope / Chapter5 / CMakeLists.txt
index e920f0e3445c94b9fd4db0c103686946d265e238..b62ed410103fa07ae349359c35e10ff93a4db896 100644 (file)
@@ -3,13 +3,13 @@ set(LLVM_LINK_COMPONENTS
   Core
   ExecutionEngine
   InstCombine
-  MC
+  Object
+  RuntimeDyld
   ScalarOpts
   Support
   native
-  mcjit
   )
 
-add_llvm_example(Kaleidoscope-Ch5
+add_kaleidoscope_chapter(Kaleidoscope-Ch5
   toy.cpp
   )