Kaleidoscope: Prune unused libdeps.
[oota-llvm.git] / examples / Kaleidoscope / Chapter5 / CMakeLists.txt
index c7d0276194cf7ff9d777e091b40b6395935122d1..b62ed410103fa07ae349359c35e10ff93a4db896 100644 (file)
@@ -3,12 +3,13 @@ set(LLVM_LINK_COMPONENTS
   Core
   ExecutionEngine
   InstCombine
-  JIT
+  Object
+  RuntimeDyld
   ScalarOpts
   Support
-  nativecodegen
+  native
   )
 
-add_llvm_example(Kaleidoscope-Ch5
+add_kaleidoscope_chapter(Kaleidoscope-Ch5
   toy.cpp
   )