Kaleidoscope: Prune unused libdeps.
[oota-llvm.git] / examples / Kaleidoscope / Chapter5 / CMakeLists.txt
index 33a0651f8c0a9d9c15707a4635ca9dc07e0c04df..b62ed410103fa07ae349359c35e10ff93a4db896 100644 (file)
@@ -1,6 +1,15 @@
-add_llvm_example(Kaleidoscope-Ch5
-  toy.cpp
+set(LLVM_LINK_COMPONENTS
+  Analysis
+  Core
+  ExecutionEngine
+  InstCombine
+  Object
+  RuntimeDyld
+  ScalarOpts
+  Support
+  native
   )
 
-add_llvm_link_components(Kaleidoscope-Ch5 jit interpreter native)
-target_link_libraries(Kaleidoscope-Ch5 LLVMCore)
+add_kaleidoscope_chapter(Kaleidoscope-Ch5
+  toy.cpp
+  )