Kaleidoscope: Prune unused libdeps.
[oota-llvm.git] / examples / Kaleidoscope / Chapter5 / CMakeLists.txt
index 138cf0c0969aa4895cae0570460980c6f860ce00..b62ed410103fa07ae349359c35e10ff93a4db896 100644 (file)
@@ -3,13 +3,13 @@ set(LLVM_LINK_COMPONENTS
   Core
   ExecutionEngine
   InstCombine
-  MC
+  Object
+  RuntimeDyld
   ScalarOpts
   Support
-  nativecodegen
-  mcjit
+  native
   )
 
-add_llvm_example(Kaleidoscope-Ch5
+add_kaleidoscope_chapter(Kaleidoscope-Ch5
   toy.cpp
   )