Recommit r246175 - Add Kaleidoscope regression tests, with a fix to make sure
[oota-llvm.git] / examples / Kaleidoscope / Chapter4 / CMakeLists.txt
index 86336debc871348f0b87e2719c3a49e0ca8d5d04..89feed143adcd53ab0ed2d5e4e1d4c4e66dccdda 100644 (file)
@@ -3,13 +3,15 @@ set(LLVM_LINK_COMPONENTS
   Core
   ExecutionEngine
   InstCombine
-  MC
+  Object
+  RuntimeDyld
   ScalarOpts
   Support
   native
-  mcjit
   )
 
-add_llvm_example(Kaleidoscope-Ch4
+add_kaleidoscope_chapter(Kaleidoscope-Ch4
   toy.cpp
   )
+
+export_executable_symbols(Kaleidoscope-Ch4)