Recommit r246175 - Add Kaleidoscope regression tests, with a fix to make sure
[oota-llvm.git] / examples / Kaleidoscope / Chapter4 / CMakeLists.txt
index 7aa18b8898871728e3280b3391061ad65193c600..89feed143adcd53ab0ed2d5e4e1d4c4e66dccdda 100644 (file)
@@ -1,6 +1,17 @@
-add_llvm_example(Kaleidoscope-Ch4
+set(LLVM_LINK_COMPONENTS
+  Analysis
+  Core
+  ExecutionEngine
+  InstCombine
+  Object
+  RuntimeDyld
+  ScalarOpts
+  Support
+  native
+  )
+
+add_kaleidoscope_chapter(Kaleidoscope-Ch4
   toy.cpp
   )
 
-add_llvm_link_components(Kaleidoscope-Ch4 jit interpreter native)
-target_link_libraries(Kaleidoscope-Ch4 LLVMCore)
+export_executable_symbols(Kaleidoscope-Ch4)