Recommit r246175 - Add Kaleidoscope regression tests, with a fix to make sure
[oota-llvm.git] / examples / Kaleidoscope / Chapter4 / CMakeLists.txt
index 45e92e4b8ca8dffc1e4aae202b38a290e5e12cde..89feed143adcd53ab0ed2d5e4e1d4c4e66dccdda 100644 (file)
@@ -3,13 +3,15 @@ set(LLVM_LINK_COMPONENTS
   Core
   ExecutionEngine
   InstCombine
-  MC
+  Object
+  RuntimeDyld
   ScalarOpts
   Support
   native
-  mcjit
   )
 
 add_kaleidoscope_chapter(Kaleidoscope-Ch4
   toy.cpp
   )
+
+export_executable_symbols(Kaleidoscope-Ch4)