Recommit r246175 - Add Kaleidoscope regression tests, with a fix to make sure
[oota-llvm.git] / examples / Kaleidoscope / Chapter4 / CMakeLists.txt
index 111332bccd0d2befd00698501211922e98d88217..89feed143adcd53ab0ed2d5e4e1d4c4e66dccdda 100644 (file)
@@ -3,13 +3,15 @@ set(LLVM_LINK_COMPONENTS
   Core
   ExecutionEngine
   InstCombine
-  MCJIT
+  Object
+  RuntimeDyld
   ScalarOpts
   Support
-  TransformUtils
   native
   )
 
 add_kaleidoscope_chapter(Kaleidoscope-Ch4
   toy.cpp
   )
+
+export_executable_symbols(Kaleidoscope-Ch4)