Recommit r246175 - Add Kaleidoscope regression tests, with a fix to make sure
[oota-llvm.git] / examples / Kaleidoscope / Chapter4 / CMakeLists.txt
index 0d1ac533f02d49a19758fadc0687da4630d8cabf..89feed143adcd53ab0ed2d5e4e1d4c4e66dccdda 100644 (file)
@@ -1,5 +1,17 @@
-set(LLVM_LINK_COMPONENTS core jit interpreter native)
+set(LLVM_LINK_COMPONENTS
+  Analysis
+  Core
+  ExecutionEngine
+  InstCombine
+  Object
+  RuntimeDyld
+  ScalarOpts
+  Support
+  native
+  )
 
-add_llvm_example(Kaleidoscope-Ch4
+add_kaleidoscope_chapter(Kaleidoscope-Ch4
   toy.cpp
   )
+
+export_executable_symbols(Kaleidoscope-Ch4)