[CMake] examples/Kaleidoscope: Prune redundant libdeps.
[oota-llvm.git] / examples / Kaleidoscope / Chapter4 / CMakeLists.txt
index 86336debc871348f0b87e2719c3a49e0ca8d5d04..2b3aed5e4558d0f9aac5041b33eedc82d256c6bf 100644 (file)
@@ -3,13 +3,13 @@ set(LLVM_LINK_COMPONENTS
   Core
   ExecutionEngine
   InstCombine
-  MC
   ScalarOpts
   Support
+  TransformUtils
   native
   mcjit
   )
 
-add_llvm_example(Kaleidoscope-Ch4
+add_kaleidoscope_chapter(Kaleidoscope-Ch4
   toy.cpp
   )