[CMake] examples/Kaleidoscope: Prune redundant libdeps.
[oota-llvm.git] / examples / Kaleidoscope / Chapter4 / CMakeLists.txt
index 7aa18b8898871728e3280b3391061ad65193c600..2b3aed5e4558d0f9aac5041b33eedc82d256c6bf 100644 (file)
@@ -1,6 +1,15 @@
-add_llvm_example(Kaleidoscope-Ch4
-  toy.cpp
+set(LLVM_LINK_COMPONENTS
+  Analysis
+  Core
+  ExecutionEngine
+  InstCombine
+  ScalarOpts
+  Support
+  TransformUtils
+  native
+  mcjit
   )
 
-add_llvm_link_components(Kaleidoscope-Ch4 jit interpreter native)
-target_link_libraries(Kaleidoscope-Ch4 LLVMCore)
+add_kaleidoscope_chapter(Kaleidoscope-Ch4
+  toy.cpp
+  )