[CMake] examples/Kaleidoscope: Prune redundant libdeps.
[oota-llvm.git] / examples / Kaleidoscope / Chapter4 / CMakeLists.txt
index 2b87e86849866f44c04fccd9dd83c808487eb74a..2b3aed5e4558d0f9aac5041b33eedc82d256c6bf 100644 (file)
@@ -3,13 +3,13 @@ set(LLVM_LINK_COMPONENTS
   Core
   ExecutionEngine
   InstCombine
-  JIT
-  MC
   ScalarOpts
   Support
-  nativecodegen
+  TransformUtils
+  native
+  mcjit
   )
 
-add_llvm_example(Kaleidoscope-Ch4
+add_kaleidoscope_chapter(Kaleidoscope-Ch4
   toy.cpp
   )