[CMake] examples/Kaleidoscope: Prune redundant libdeps.
[oota-llvm.git] / examples / Kaleidoscope / Chapter4 / CMakeLists.txt
index 0d1ac533f02d49a19758fadc0687da4630d8cabf..2b3aed5e4558d0f9aac5041b33eedc82d256c6bf 100644 (file)
@@ -1,5 +1,15 @@
-set(LLVM_LINK_COMPONENTS core jit interpreter native)
+set(LLVM_LINK_COMPONENTS
+  Analysis
+  Core
+  ExecutionEngine
+  InstCombine
+  ScalarOpts
+  Support
+  TransformUtils
+  native
+  mcjit
+  )
 
-add_llvm_example(Kaleidoscope-Ch4
+add_kaleidoscope_chapter(Kaleidoscope-Ch4
   toy.cpp
   )