llvm/examples: Suppress building a few JIT examples.
[oota-llvm.git] / examples / ExceptionDemo / CMakeLists.txt
index 293c66b2298d6cf3f3e2094176124098ecafdb52..f1715be4156be1ab1907c7580164587fc6ee3c99 100644 (file)
@@ -1,5 +1,21 @@
+set(LLVM_LINK_COMPONENTS
+  Core
+  ExecutionEngine
+  MC
+  MCJIT
+  RuntimeDyld
+  Support
+  nativecodegen
+  )
+
+# Enable EH and RTTI for this demo
+set(LLVM_REQUIRES_EH 1)
+set(LLVM_REQUIRES_RTTI 1)
+
+set(EXCLUDE_FROM_ALL ON)
+
 add_llvm_example(ExceptionDemo
   ExceptionDemo.cpp
   )
 
-add_llvm_link_components(ExceptionDemo jit nativecodegen)
+export_executable_symbols(ExceptionDemo)