Add bogus conditional branch before stlx
[oota-llvm.git] / examples / ExceptionDemo / CMakeLists.txt
index 432e683a13f285ba864d641513957eb240a58d44..793cf291ca6f110eae23c396e24c2ee3cd050bcd 100644 (file)
@@ -1,8 +1,21 @@
-set(LLVM_LINK_COMPONENTS jit nativecodegen)
-set(LLVM_REQUIRES_EH 1)
+set(LLVM_LINK_COMPONENTS
+  Core
+  ExecutionEngine
+  MC
+  MCJIT
+  RuntimeDyld
+  Support
+  Target
+  nativecodegen
+  )
+
+# Enable EH and RTTI for this demo
+if(NOT LLVM_ENABLE_EH)
+  message(FATAL_ERROR "ExceptionDemo must require EH.")
+endif()
 
 add_llvm_example(ExceptionDemo
   ExceptionDemo.cpp
   )
 
-set_target_properties(ExceptionDemo PROPERTIES ENABLE_EXPORTS 1)
+export_executable_symbols(ExceptionDemo)